last update

AndroidStudioで「Could not find any version that matches…」エラーが出たので対処

AndroidStudioError2014SDKRepository_2_sh

久しぶりに Android Studio と Android SDK をアップデートしたら、ビルド時にこんなエラーが出るようになったので対処しました。

Error:A problem occurred configuring project ':app'.
> Could not resolve all dependencies for configuration ':app:_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:19.+.
     Required by:
         ***APPNAME***:app:unspecified

Android Studio のツールバー →「SDK Manager」から、

  • Android Support Repository
  • Android Support Library
  • Google Repository

にチェックを入れてインストールして解決。

AndroidStudioError2014SDKRepository_1_sh

ググっても「Google Repository」にチェックを入れればOK。みたいな感じだったのでちょっと悩みました。

最低限、何が必要なのかまでは確認していませんが、とりあえずこれだけチェックを入れたら動いたのでメモ。

この記事への1件のコメントがあります

  1. あきたじゅん says:

    5年前

    まさに掲題のエラーに悩まされておりました。
    ありがとうございました!

コメントを記入