Desire HDでRadioにあったrilを導入する

inspire

CyanogenMod などのROMを焼いている人の中には、謎のバッテリドレインを経験したことがある人もいると思います。

そういう場合、Radioとrilのバージョンが合っているか確認するのがセオリーですが、ここでは、そういう時に役立つ Desire HD の Radio と ril に関連する xda Developer のスレッドを列挙します。

※ 2012/2/1 DesireHDにCyanogen Mod 7.1.0 Stableを焼く場合、ril更新は推奨されていません。更新すると3G接続ができなくなったりします。
手元の環境では ril / Radioの不整合を承知の上でRadioだけ「Radio_12.65.60.29_26.14.04.28_M.zip」を使っていますが、かなり調子よいです。

Radio と ril の関係は、これが分かりやすい。

[RADIO] HTC Desire's Family RIL Packages [08 JUN 2011]

http://forum.xda-developers.com/showthread.php?t=902752

 

Radioに対応したrilはこちら

[RIL] Radio Interface Libraries

http://forum.xda-developers.com/showthread.php?t=1040986

 

Radioとrilのセットはこちら

[RADIO+RIL] New radio 12.62.60.27_26.13.04.19_M from DHD 3.06.405.1 GB base

http://forum.xda-developers.com/showthread.php?t=996630

 

個人的には、「RADIO_12.54.60.25P_26.09.04.11_M2」+「RIL_12.54.60.25P_26.09.04.11_M2」の組み合わせが鉄板と思っています。

rilのバージョンは、ターミナルから以下のコマンドで調べられます。

$ su

# getprop "gsm.version.ril-impl"

以上、特に新しい情報ではないんですが、再設定する機会があったので、自分用メモとして。

この記事へのコメント(1件)

  1. [memo]AndroidのROM焼き関連 | 森のえのきさん says:

    8年前

    [...] Desire HDでRadioにあったrilを導入する http://www.teradas.net/archives/1859/ [...]

コメントを記入