last update 2021年1月18日 10:48

【CentOS 7】libzip5の依存性問題の解決メモ

解決したのは昨年の話にはなりますが、自分用メモ。

CentOS 7.9 だったか 7.8 で Remi Repository 版の PHP 7.1 を yum update しようとしたら、libzip5 の依存性問題が発生したので対処。

エラー内容はこんな感じ。

 --> 依存性解決を終了しました。
 エラー: パッケージ: php-pecl-zip-1.19.2-1.el7.remi.7.1.x86_64 (remi-php71)
              要求: libzip5(x86-64) >= 1.7.3
             インストール: libzip5-1.7.1-1.el7.remi.x86_64 (@remi)
                 libzip5(x86-64) = 1.7.1-1.el7.remi
  問題を回避するために --skip-broken を用いることができます。
  これらを試行できます: rpm -Va --nofiles --nodigest

調べたところ、OS のパッケージを上書きしない remi-safe にすればアップデートできそうだと分かったので、以下のコマンドを実行。

yum-config-manager --enable remi-safe

その後、普通に yum update したところ、問題なくアップデートを完了できました。

当時、日本語情報がなかった記憶があるので(現在は不明も)、念のため書いておきます。

参考情報:

コメントを記入